View unanswered posts | View active topics It is currently Sun Dec 16, 2018 7:06 am



Reply to topic  [ 4 posts ] 
 Intel NUC DC53427HYE with USB NIC (ASIX) as second interface 
Author Message

Joined: Thu Apr 24, 2014 7:12 am
Posts: 3
Reply with quote
Post Intel NUC DC53427HYE with USB NIC (ASIX) as second interface
Hi all,

I'm pretty new to ESXi, so please forgive me if my problems are maybe a bit odd...

I'd like to use an Intel NUC (3rd Gen) as ESXi server (5.5) in the context of a malware sandbox. Actually I managed to create a modified ISO so the internet ethernet adapter is recognized. But the guests require a second ethernet interface, which should not be routed into the same network for security reasons, so my thought was to add an USB ethernet adapter as second NIC. Unfortunately it is not recognized by ESXi as network adapter. I did manage though to just connect the USB device itself to a guest, and there (running Windows) the adapter is recognized, so I thought that solves the issue. But of course, for the sandbox it is required to have several guests, and they also sometimes run at the same time. It seems the USB device can't be shared between the guests - only the first one gets it, the next ones don't (maybe turning off the USB arbitrator would help, but I doubt it). So it comes back to the problem that ESXi itself must also recognize the device, then it can be bridged to the guests.

The adapter I got is a "ASIX AX88179 USB 3.0 to Gigabit Ethernet Adapter" with device ID 0b95:1790 (branded as Digitus). It seems this chipset is not supported by ESXi. I thought about buying another USB adapter, but all that I checked in a local webshop also seem to use an ASIX chipset, so probably none of these work (if you have any suggestion what might work, please let me know).

By googling a lot around, I found this huge thread on this forum: http://www.vm-help.com/forum/viewtopic.php?f=24&t=4320 (ASIX AX88179_178a USB NIC Driver by Trickstarter). It is mainyl about a Mac Mini, but I think the driver this thread is about might also work in my case. I did also find 2 files ax88179vz026 and usbnetvz026 somewhere in the middle of the thread and downloaded them, and using the instructions at http://www.v-front.de/p/esxi5-community-packaging-tools.html I tried to create a vib file; basically I created a etc/vmware/driver.map.d/ax88179vz026.map file with content
Code:
regtype=linux,bus=pci,id=0b95:1790 0000:0000,driver=ax88179vz026,class=network

and a usr/share/hwdata/driver.pciids.d/ax88179vz026.ids with
Code:
0b95  ASIX
        1790  ASIX AX88179 USB 3.0 to Gigabit Ethernet Adapter

And then created the tgz as
Quote:
$ tar cvzf ../ax88179vz026.tgz *
a etc
a etc/vmware
a etc/vmware/driver.map.d
a etc/vmware/driver.map.d/ax88179vz026.map
a usr
a usr/lib
a usr/share
a usr/share/hwdata
a usr/share/hwdata/driver.pciids.d
a usr/share/hwdata/driver.pciids.d/ax88179vz026.ids
a usr/lib/vmware
a usr/lib/vmware/vmkmod
a usr/lib/vmware/vmkmod/ax88179vz026

Finally translated it to a vib.

Unfortunately, when I install and reboot, I get a PSOD... and this is where I stand now.

I don't really know what to do with the usbnetvz026 file - probably it should replace the existing usbnet, but just overwriting it doesn't help (it is resetted at boot time).

Any help in this matter would be highly welcome :-)

Cheers, Andy


Thu Apr 24, 2014 7:35 am
Profile

Joined: Tue May 06, 2014 12:23 pm
Posts: 2
Reply with quote
Post Re: Intel NUC DC53427HYE with USB NIC (ASIX) as second inter
Hi,

i have the same issues with an Intel D34010WYK. I tried Tricksters drivers actually if you install esxi and load the driver (usb and asix) as modules afterwards it works you can assign the NIC. But if you plug in the ethernetcable into the NIC esxi crashes. Thats where i quit, i have a spare NUC here but i have no skills in coding and now nothing about driver.

I have the same NIC chipset as you so you might be able to get it to run using my method. It's not persistend but at least you can test the drivers.

Store both files from Trickster in /usr/bin/vmware/vmkmod
and load both first usb 2nd ASIX with vmkload_mod /path/driver

you can check if it worked with esxcfg-nics -l

then add the nic to a switch
esxcli network vswitch standard uplink add -u vusb0 -v vSwitch1

I hope this helps

Christian


Tue May 06, 2014 1:23 pm
Profile

Joined: Thu Apr 24, 2014 7:12 am
Posts: 3
Reply with quote
Post Re: Intel NUC DC53427HYE with USB NIC (ASIX) as second inter
Hi Christan,

Thanks, I'll try this out. I "solved" the issue with a bit an ugly workaround meanwhile: I live with the esxi host not recognizing the adapter at all, but just pass it as an USB device to the guest and let the guest do the job. Unfortunately only one guest can use the adapter, it is not sharable (at least I would not know how to share it), so I decided to assign it to one special guest which is running all the time and acts as a router for a second virtual switch where the other guests run. Together with some iptables kung-fu that now works, but it's not really a nice solution (plus it eats additional precious resources for the additional guest that does nothing else but shifting around ip packets...). Well, if the mountain doesn't want to go to the prophet.... :-)

Andy


Sun May 11, 2014 1:14 pm
Profile

Joined: Tue May 06, 2014 12:23 pm
Posts: 2
Reply with quote
Post Re: Intel NUC DC53427HYE with USB NIC (ASIX) as second inter
Hi Andy,
yeah i thought about using cisco virtual ASA and pass the nics through but this does not resolve my problem that my DRS and migration performance is to slow with only one gig nic.

Regards
Christian


Mon May 12, 2014 7:06 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.