View unanswered posts | View active topics It is currently Wed Sep 20, 2017 1:20 am



Reply to topic  [ 4 posts ] 
 VMDirectPath Ceton InfiniTV Cable Card TV Tuner Hangs ESXi 
Author Message

Joined: Thu Jun 30, 2011 8:18 pm
Posts: 5
Reply with quote
Post VMDirectPath Ceton InfiniTV Cable Card TV Tuner Hangs ESXi
Hi guys,

OK first of all I know this is way off the HCL stuff here so please no lectures :)

I have a Dell Precision T5500 here, which uses the 5200 chipset and is equipped with a Xeon E5645 6-core processor with hyperthreading. I have 24GB of RAM installed (ECC Registered DDR3).

The slot situation is that it has a PCI-X slot behind its own bridge. In there I have a Silicom 6-port Gigabit NIC (works great with ESXi as it's intel based--was only $50 on ebay!). There is also a single PCI slot (behind its own PCI bridge) with nothing in it at the moment. There are then two PCIe x16 slots and two PCIe x8 slots. There is no on-board video on this machine so I have an old radeon x300 in one of the x16 slots and this ceton tuner card (which is a x1 device) in one of the x8 slots. I have tried swapping between the two x16 and x8 slots and get the same behavior.

So I have set the tuner card as available for pass-thru, rebooted, and it shows up as enabled (ESXi sees it as "Unknown Pre VGA Device"). So I assign it to a Win 7 x64 virtual machine with 1CPU and 2GB of RAM--nothing else special. When I power on the virtual machine, it gets some percentage of the way done--lately it's been 80% but the very first time I remember it got to 95% and sometimes it's frozen at 40%. At that point, the vSphere client app completely loses contact with the server. Sometimes if I let the server sit long enough a pink screen will show up (wasn't able to glean any useful info off of them but I took a pic with my phone and can post those if anyone wants). But basically ESXi locks HARD. Only thing I can do is power off and reboot and then everything is fine (until I try to power on the virtual machine again).

I tried creating a brand new VM without anything actually installed and assigned the PCI device to it and it did the same thing, so I don't think it's a corrupt vmx file or anything.

I looked through VMWare's simple VMDirectPath troubleshooting PDF and I did try editing the vmx to disable IOAPIC for the device but there was absolutely no change. I haven't tried any other changes to the vmx file or the pci map yet.

I have booted up this system (leaving all cards where they are) into a different hard drive with a stock install of Win7 x64 on it and verified that the card works, is detected by Windows, and drivers installed successfully. So the card itself appears to be fine.

I've had success passing through all kinds of other stuff, so I have to say I was sort of surprised to see this one fail so hard. I'm not sure all exactly what devices are on the card--I know it does have a MAC address so it must have a NIC of some sort, along with USB-based tuners (though to be clear there are no actual ethernet or USB ports involved--it's all located on the PCIe card.

The log file in the virtual machine folder doesn't look to be much help. I have attached it anyway just in case there is something of use in there.

Anyone have any ideas? Not being that familiar with ESXi, I'm just not even sure what else I can try. I have to keep the PCI-X NIC installed because the on-board NIC isn't compatible with ESXi, and i have to keep the graphics card installed because this system has no onboard video. But I've removed all other extraneous devices from the system.

I would very much appreciate any hints or ideas to get this card working. It was purchased long ago (my fault) so returning for a refund isn't an option. I know there are other tuner options now (Ethernet based and USB) and I will probably look to those if I can't get this card working, but I'm not ready to give up quite yet.

Thanks!


Attachments:
vmware.log [8.63 KiB]
Downloaded 255 times
Wed Jul 20, 2011 1:03 pm
Profile

Joined: Thu Jun 30, 2011 8:18 pm
Posts: 5
Reply with quote
Post Re: VMDirectPath Ceton InfiniTV Cable Card TV Tuner Hangs ES
Well, I tried the same card on my work ESXi server, which is a Dell PowerEdge T110 (on the HCL :D ) and it worked just fine over there... well I should say it passed through fine to a Windows 7 VM. I was able to power on the VM, it booted and detected the hardware.

So I guess it's just a hardware conflict of some kind between the Precision T5500 and the Ceton card. Guess that's why the HCL is important :).

If anyone has any ideas, I would still be interested in getting the Ceton working on the T5500. I'm just not sure what else I can try at this point.


Wed Jul 20, 2011 9:56 pm
Profile

Joined: Tue Mar 09, 2010 9:00 pm
Posts: 2
Reply with quote
Post Re: VMDirectPath Ceton InfiniTV Cable Card TV Tuner Hangs ES
When you finally got this working on your other ESX box, did you still have to disable IOAPIC?


Mine is working but I am noticing some performance issues.


Fri Mar 23, 2012 4:35 pm
Profile

Joined: Mon Jun 13, 2011 4:37 am
Posts: 1
Reply with quote
Post Re: VMDirectPath Ceton InfiniTV Cable Card TV Tuner Hangs ES
For those that have got this working, please let me know the hardware that you have working - e.g., motherboard. I am currently using a Supermicro X8SIL-F-O with ESXi v5 and the machine crashes once the guest boots with the Ceton passed through.


Thu May 03, 2012 12:32 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.