View unanswered posts | View active topics It is currently Wed Sep 20, 2017 2:02 pm



Reply to topic  [ 3 posts ] 
 Please help with random host network disconnect issue. 
Author Message

Joined: Tue Jun 23, 2009 12:30 pm
Posts: 2
Reply with quote
Post Please help with random host network disconnect issue.
So I had a pretty easy and uneventful install of ESXi 4 on the following hardware:

BIOSTAR NF61S-M2A
AMD Athlon 64 X2 4000+
Intel PWLA8391GTL 10/ 100/ 1000Mbps PCI PRO/1000 GT

I have been able to connect to my host using the vsphere client and I've created several guests.

Now my issue is that my host server will randomly become unreachable on my network after a couple of hours. From the local host, I can see, via the "Customize System" menu, that my network adapter status is "Connected". I've had this issue whether my adapter is statically assigned or on DHCP. This has also happened with and without guests powered on.

In Tech Support Mode, the host can ping itself as well as the guest system's IP addresses, but it cannot ping the gateway or any other physical machines on my network. I've connected a PC directly to the host via crossover and was still unable to get any reply.

Up until recently, the only way I have been able to restore the Hosts connection with the rest of my network was to reboot the host. I have since found out that if I run the following command in Tech Support Mode, it will also restore my Hosts connection with my network (albeit for a couple more hours...):

vim-cmd hostsvc/net/pnic_setlinkspeed vmnic0

Sorry for the long post. I just want to provide all the details I can.

Thanks!


Tue Jun 23, 2009 12:49 pm
Profile
Site Admin

Joined: Mon Mar 16, 2009 10:13 pm
Posts: 3880
Reply with quote
Post Re: Please help with random host network disconnect issue.
A few questions -
1) I take it that the VMs also loose their network connection?
2) Do you see any errors in /var/log/messages?
3) Are you able to set the speed / duplex at the switch level?
4) Do you have the NIC set to auto negotiate or to specific settings in the VI client.
5) Any errors on the switch itself?

_________________
Dave Mishchenko
VMware vExpert 2009-2013
Image
Now available - VMware ESXi: Planning, Implementation, and Security
Also available - vSphere Quick Start Guide


Wed Jun 24, 2009 7:42 pm
Profile

Joined: Tue Jun 23, 2009 12:30 pm
Posts: 2
Reply with quote
Post Re: Please help with random host network disconnect issue.
Thank you so much for the reply!

1) I take it that the VMs also loose their network connection?
- I am able to ping the VMs ip addresses from the host console, but I have no way of connecting to them to see if they can ping back.

2) Do you see any errors in /var/log/messages?
- I've checked the messages log and there are no apparent errors around the time of the disconnect.

3) Are you able to set the speed / duplex at the switch level?
- No, this is just connected to an unmanaged linksys switch

4) Do you have the NIC set to auto negotiate or to specific settings in the VI client.
- I originally had the nic set on Auto, but I have also set the nice manually to 100FULL and still had the same issue.

5) Any errors on the switch itself?
- No error log on my switch.


Thu Jun 25, 2009 2:13 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.