View unanswered posts | View active topics It is currently Sat Oct 19, 2019 10:26 pm



Reply to topic  [ 47 posts ]  Go to page 1, 2, 3, 4, 5  Next
 Failed to load lvmdriver on HP Z600 workstation w/ BCM5764M 
Author Message

Joined: Sun Oct 18, 2009 10:20 pm
Posts: 11
Reply with quote
Post Failed to load lvmdriver on HP Z600 workstation w/ BCM5764M
I am trying to install ESXi 4.0 on my new HP Z600 workstation, but always stop at "Failed to load lvmdriver".
I'm new at ESX... after a lot of Google, I decide to post my questions here, hope can get some help.

1. HW info
HP Z600
Intel 5520 chipset (similar to X58)
SATA AHCI/RAID controller
Onboard NIC: Broadcom BCM5764M
Add-in PCI-e NIC: BCM5761

2. What I tried.
1) remove PCI-e NIC, "Failed to load lvmdriver"
2) remove PCI-e NIC, and disable onboard NIC in BIOS, "Failed to load lvmdriver"
3) change storage controller mode from SATA/RAID to IDE, and remove/disable NIC, still fail to load lvmdriver.

3. my questions so far:
1) does "Failed to load lvmdriver" means no NIC or storage controller driver? Is anything else can lead to this failure?
2)I'm trying oem.tgz (http://www.vm-help.com/esx40i/customize_oem_tgz.php), will it help to fix my issue? I have no idea, but trying.


Last edited by scarf on Mon Oct 19, 2009 12:04 am, edited 1 time in total.



Sun Oct 18, 2009 10:50 pm
Profile
Site Admin

Joined: Mon Mar 16, 2009 10:13 pm
Posts: 3880
Reply with quote
Post Re: Failed to load lvmdriver on HP Z600 workstation w/ BCM5764M
The LVM error is due to ESXi not finding a NIC that it can use. Can you post the PCI id for the NICs - http://www.vm-help.com/esx40i/Hardware_support.php?

_________________
Dave Mishchenko
VMware vExpert 2009-2013
Image
Now available - VMware ESXi: Planning, Implementation, and Security
Also available - vSphere Quick Start Guide


Sun Oct 18, 2009 11:16 pm
Profile

Joined: Sun Oct 18, 2009 10:20 pm
Posts: 11
Reply with quote
Post Re: Failed to load lvmdriver on HP Z600 workstation w/ BCM5764M
Thanks Dave's quick response.

Currently, I can't boot with ESXi install CD. So I'm going to get PCI ID under Windows.

BTW, I just try my workstation with Intel pro/1000 82540EM Gigabit Ethernet Controller (other NIC disabled) and AHCI mode.
I can see the ESXi Installer loaded e1000 and AHCI driver in the installation progress. The lvmdriver failure always come up after ACHI driver loaded. Does it mean the NIC is not the key point?

Thanks,


Sun Oct 18, 2009 11:52 pm
Profile

Joined: Sun Oct 18, 2009 10:20 pm
Posts: 11
Reply with quote
Post Re: Failed to load lvmdriver on HP Z600 workstation w/ BCM5764M
PCI id screenshot.


Attachments:
File comment: Storage
PCIID_Storage.jpg
PCIID_Storage.jpg [ 29.31 KiB | Viewed 10995 times ]
File comment: PCI ID for NIC
PCIID_NIC.jpg
PCIID_NIC.jpg [ 63.74 KiB | Viewed 10994 times ]
Mon Oct 19, 2009 12:08 am
Profile

Joined: Sun Oct 18, 2009 10:20 pm
Posts: 11
Reply with quote
Post Re: Failed to load lvmdriver on HP Z600 workstation w/ BCM5764M
From VMware HCL, the BCM5764M should be supported

http://www.vmware.com/resources/compati ... 76&release[]=-1&datePosted=-1&partnerId[]=12&ioTypeId[]=-1&vid=&did=&svid=&ssid=&rorre=0

But what it means in notes

Device Drivers:

* 1. tg3 version 3.86


Attachments:
File comment: HCL_BCM5764M
HCL_BCM5764M.JPG
HCL_BCM5764M.JPG [ 15.11 KiB | Viewed 10994 times ]
Mon Oct 19, 2009 12:16 am
Profile
Site Admin

Joined: Mon Mar 16, 2009 10:13 pm
Posts: 3880
Reply with quote
Post Re: Failed to load lvmdriver on HP Z600 workstation w/ BCM5764M
If you see this list ESXi won't recognize the NICs and you'll need a NIC ESXi can use to get through the install process.
http://www.vm-help.com/esx40i/Hardware_support.php

I would boot with the install CD again and when you get to the error
1) press ALT+F1 to get to the console - login will be root / no password
2) run esxcfg-nics -l - you should get nothing for output
3) run vmkload_mod tg3.o to load the Broadcom driver.
4) then run esxcfg-nics -l again to see if the driver is able to load up OK for one of the NICs.

If that works then you can look at using a custom oem.tgz file for the install.

_________________
Dave Mishchenko
VMware vExpert 2009-2013
Image
Now available - VMware ESXi: Planning, Implementation, and Security
Also available - vSphere Quick Start Guide


Mon Oct 19, 2009 12:19 am
Profile
Site Admin

Joined: Mon Mar 16, 2009 10:13 pm
Posts: 3880
Reply with quote
Post Re: Failed to load lvmdriver on HP Z600 workstation w/ BCM5764M
There might also be an updated driver for the NIC (hence it appears on the HCL).

_________________
Dave Mishchenko
VMware vExpert 2009-2013
Image
Now available - VMware ESXi: Planning, Implementation, and Security
Also available - vSphere Quick Start Guide


Mon Oct 19, 2009 12:21 am
Profile

Joined: Sun Oct 18, 2009 10:20 pm
Posts: 11
Reply with quote
Post Re: Failed to load lvmdriver on HP Z600 workstation w/ BCM5764M
Fail to access Console, but got some information under Alt+F12 (vmkernel log)
an alert says: Failed to trying to get a valid VMKernel MAC address,.... Please add/configure VMKernel NICs.

Alt+F11 (Installer progress bar and status)
stopped at: lvmdriver failed to load with status -1,-1, 0xbad0001

Alt+F1 should be shell terminal, but not response to keyboard input, just show .....Fail to load lvmdriver...

Alt+F2 just echo keyboard inputs, can't login and control.



Anyway, from the log, we can sure that this issue due to NIC driver.
But how to fix it? Anybody could give some help? I'm not so familiar with ESX and Linux script. :oops:


Mon Oct 19, 2009 12:45 am
Profile
Site Admin

Joined: Mon Mar 16, 2009 10:13 pm
Posts: 3880
Reply with quote
Post Re: Failed to load lvmdriver on HP Z600 workstation w/ BCM5764M
Did you type in unsupported at the console and then press enter. you won't get text feedback for that.

_________________
Dave Mishchenko
VMware vExpert 2009-2013
Image
Now available - VMware ESXi: Planning, Implementation, and Security
Also available - vSphere Quick Start Guide


Mon Oct 19, 2009 3:23 pm
Profile

Joined: Sun Oct 18, 2009 10:20 pm
Posts: 11
Reply with quote
Post Re: Failed to load lvmdriver on HP Z600 workstation w/ BCM5764M
unsupported Works!

Both BCM5764M and BCM5761 listed in the output of esxcfg-nics -l after vmkload_mod tg3.o.

How to proceed with OEM.tgz? Could you give same advice for quick start?
Thanks,


Mon Oct 19, 2009 5:42 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 47 posts ]  Go to page 1, 2, 3, 4, 5  Next

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.