View unanswered posts | View active topics It is currently Thu Jun 22, 2017 11:00 pm



Reply to topic  [ 5 posts ] 
 Adaptec 2405 Issue 
Author Message

Joined: Sat Sep 19, 2009 4:22 am
Posts: 2
Reply with quote
Post Adaptec 2405 Issue
Hello everyone, I hope someone can help me with this I have been struggling with it for over a week.

OK so I have the latest build of ESXi 4.0 installing on a Asus M3N78-VM board with an adaptec 2405 Raid controller.

When I install ESXi it sees the controller and the raid voumes I perform the install and then reboot then I get the infamous "Cannot locate boot partition" error.

During install the lspci shows the device as VMHBA4 with device id 9005:0285 9005:02d5.

I built custom simple.map and pci.ids files and burned the ISO install image again making sure to use both the boot cd oem.tgz and replacing the embedded one in the .dd image.

Again same results.

booting from a usb key yeilds the same result the adapter shows as VMHBA4 with the same PCIIDs but it doesn't apear that it is loading the aacraid driver. when booting from usb key, after boot if I run VMKMOD_LOAD AACRAID it loads successfully and whola my raid volumes are recognized and available for data store creation.

Am I missing something here? Can anyone help me out? is there a way to force ESXi to load various modules on boot? I really don't want to be booting from flash drive I prefer to use my RAID volume to house the host OS. Thank you in advance.


Sat Sep 19, 2009 4:33 am
Profile

Joined: Sat Sep 19, 2009 4:22 am
Posts: 2
Reply with quote
Post Re: Adaptec 2405 Issue
I resolved this issue by redoing the simple.map and pci.ids file and removing all the adaptec entries except the high level one -

2009:0285 0000:0000 storage aacraid

2009:0285 Adaptec SCSI Controller

for some reason ESXi was not properly identifiying or loading the driver for the actual device ID so by using the high level wild card id (0000:0000) it appears to have worked and it now loads the aacraid driver and finds the boot volume on my raid 1 array.


Sat Sep 19, 2009 8:08 am
Profile
Site Admin

Joined: Mon Mar 16, 2009 10:13 pm
Posts: 3880
Reply with quote
Post Re: Adaptec 2405 Issue
Thanks for posting your fix.

_________________
Dave Mishchenko
VMware vExpert 2009-2013
Image
Now available - VMware ESXi: Planning, Implementation, and Security
Also available - vSphere Quick Start Guide


Sat Sep 19, 2009 1:24 pm
Profile

Joined: Sat Oct 03, 2009 3:20 pm
Posts: 3
Reply with quote
Post Re: Adaptec 2405 Issue
I have a similar problem with an ASUS KFN4-DRE and an Adaptec 2405.

I get the pink screen error with no where to dump data.

Im having some big trouble understanding where to find simple.map and pci-ids to update them with the change you suggested.

Im not sure how to create an oem.tgz with those two files because the oem.tgz is empty to begin with on the esxi 40 install cd.

Its frustrating because this controller is on the official vmware certified hardware list. Also because im not sure what questions to ask. The answer is on this thread If someone could please show me what and how regarding these files.


Fri Nov 20, 2009 8:51 pm
Profile

Joined: Sat Oct 03, 2009 3:20 pm
Posts: 3
Reply with quote
Post Re: Adaptec 2405 Issue
I downloaded the new 4.0 update 1 and I can now get farther into the installation. Maybe my original download was bad, who knows.

However, during the install when asked to press enter to continue or esc to quit - the usb keyboard turns off at this stage.

My hardware is so simple, I have no clue why my usbs are not responding during the install.


Sat Nov 21, 2009 8:51 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.