temp.vm-help.com
http://www.vm-help.com/forum/

driver build for Realtek 8168 version 8.037.00 failed
http://www.vm-help.com/forum/viewtopic.php?f=34&t=4452
Page 1 of 1

Author:  mazebaer [ Fri Nov 01, 2013 4:31 pm ]
Post subject:  driver build for Realtek 8168 version 8.037.00 failed

trickstarter described in a fantastic manner how to compile new drivers for ESXI
I tried this for myself with the realtek 8168 driver 8.037
therefore, I need a driver for a 8111G network card
While compiling I get some errors. Perhaps someone have an idea, how to fix this

Thanks

Code:
vmkdrivers/src_9/drivers/net/r8168/r8168_n.c: In function 'rtl8168_init_one':
vmkdrivers/src_9/drivers/net/r8168/r8168_n.c:17110: error: 'struct net_device' has no member named 'poll'
vmkdrivers/src_9/drivers/net/r8168/r8168_n.c:17110: error: 'struct net_device' has no member named 'weight'
vmkdrivers/src_9/drivers/net/r8168/r8168_n.c:17262:35: error: macro "INIT_WORK" passed 3 arguments, but takes just 2
vmkdrivers/src_9/drivers/net/r8168/r8168_n.c: In function 'rtl8168_open':
vmkdrivers/src_9/drivers/net/r8168/r8168_n.c:17262: error: 'INIT_WORK' undeclared (first use in this function)
vmkdrivers/src_9/drivers/net/r8168/r8168_n.c:17262: error: (Each undeclared identifier is reported only once
vmkdrivers/src_9/drivers/net/r8168/r8168_n.c:17262: error: for each function it appears in.)
vmkdrivers/src_9/drivers/net/r8168/r8168_n.c:18665:38: error: macro "PREPARE_WORK" passed 3 arguments, but takes just 2
vmkdrivers/src_9/drivers/net/r8168/r8168_n.c: In function 'rtl8168_schedule_work':
vmkdrivers/src_9/drivers/net/r8168/r8168_n.c:18665: error: 'PREPARE_WORK' undeclared (first use in this function)
vmkdrivers/src_9/drivers/net/r8168/r8168_n.c: In function 'rtl8168_rx_interrupt':
vmkdrivers/src_9/drivers/net/r8168/r8168_n.c:19139: error: 'struct net_device' has no member named 'quota'
vmkdrivers/src_9/drivers/net/r8168/r8168_n.c: In function 'rtl8168_interrupt':
vmkdrivers/src_9/drivers/net/r8168/r8168_n.c:19342: error: too few arguments to function 'netif_rx_schedule_prep'
vmkdrivers/src_9/drivers/net/r8168/r8168_n.c:19343: error: too few arguments to function '__netif_rx_schedule'
vmkdrivers/src_9/drivers/net/r8168/r8168_n.c: In function 'rtl8168_poll':
vmkdrivers/src_9/drivers/net/r8168/r8168_n.c:19370: error: 'struct net_device' has no member named 'quota'
vmkdrivers/src_9/drivers/net/r8168/r8168_n.c:19370: error: 'struct net_device' has no member named 'quota'
vmkdrivers/src_9/drivers/net/r8168/r8168_n.c:19382: error: 'struct net_device' has no member named 'quota'
vmkdrivers/src_9/drivers/net/r8168/r8168_n.c:19385: error: too few arguments to function 'netif_rx_complete'
build@ubuntu:~/vsphere/vmkdrivers-gpl$ ^C
build@ubuntu:~/vsphere/vmkdrivers-gpl$

Author:  rjp421 [ Sun Nov 03, 2013 6:51 am ]
Post subject:  Re: driver build for Realtek 8168 version 8.037.00 failed

I need to build the r8168 drivers for my Realtek 8112L NIC, and tulip drivers for a DFE-570TX quad port NIC.

I set up a CentOS 5.3 VM, but have not been successful in setting up the build environment yet.

If anyone has any updated tips on the ESXi 5.5 build environment, please share! All of the current How-To's are for 4.x, or 5.0/5.1.

Thanks to everyone who has been working on these drivers, as im currently using the r8168_8.0.36 updated drivers found on these forums.

Cheers! :)

Page 1 of 1 All times are UTC - 8 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/