View unanswered posts | View active topics It is currently Tue Dec 12, 2017 7:44 am



Reply to topic  [ 1 post ] 
 Non-supported FC HBA works with different driver? How 2 Fix 
Author Message

Joined: Sun May 05, 2013 2:12 pm
Posts: 1
Reply with quote
Post Non-supported FC HBA works with different driver? How 2 Fix
Hi,

I've got a home lab with three ESXi 5.1 hosts, 2 running on off the shelf Gigabyte motherboards, and one on a Dell 2900.

I have been running for a couple years on some cheap old 2GB Fiber Channel hardware I got off of ebay (I know I can do iSCSI, and I do, as well as NFS, but I want the experience of the FC because it's relevant for work)

I recently found a cheap 4gb switch, and some cheap 4gb FC cards, which I bought to upgrade onto.

My trouble is that the cards I bought are apparently not officially supported. They're Emulex LPE111-e cards, which are apparently their "SMB" cards, and don't have any ESX drivers, although there seem to be Linux drivers of some flavor.

The irony is that while if I install these cards by themselves, they're ignored by ESXi 5.1, but if I leave my old card in, which is detected as an "LP9000" card, then the 4gb card is ALSO detected, as a "Zepher LightPulse" HBA. I have made all kinds of changes in the BIOS trying to see if perhaps it was a PCIe configuration or detection problem, but in any configuration I can come up with, and in THREE separate hosts, but it acts the same, and I'm assuming now that although technically not supported, this card just happens to be compatible with whatever the "Zepher" card is, but that the PCI identification isn't triggering the driver to load.

Is there a way to edit the driver that works, to make it load when only the LPE card is installed ?

Oh.. One more test I did was to take out all but the one LPE card, and install Windows 8, and Windows did see the card, after installing the "SMB" drivers provided by Emulex.

Any help would be great! They're working, since I Have this workaround, but I do have one machine that I'd like to use, which does not have a classic 32 bit PCI slot, so I can't install an old card in there just to make the driver install..

Thanks!
-Steve


Sun May 05, 2013 2:31 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.