View unanswered posts | View active topics It is currently Sun Sep 15, 2019 6:43 pm



Reply to topic  [ 3 posts ] 
 Intel EtherExpress Pro 100+ [need driver] 
Author Message

Joined: Mon Oct 08, 2012 7:44 am
Posts: 2
Reply with quote
Post Intel EtherExpress Pro 100+ [need driver]
Hi!

I need driver for Intel EtherExpress Pro 100+ (dual), chipset family 8255x.
Yes, I know, old hardware, but still useful.

Does anyone have a driver, or could build for me?


Mon Oct 08, 2012 7:56 am
Profile

Joined: Wed May 29, 2013 7:10 pm
Posts: 4
Reply with quote
Post Re: Intel EtherExpress Pro 100+ [need driver]
This is an old post for an old NIC, but it might be useful for somebody like me who needed this drivers.
Here's a vib file with the e100 driver for the intel 8255x family I used for testing. The original drivers can be found here, and these are the changes I made (following trikstarters guide), in case somebody wants to check it out.
On e100.c I changed the lines in function e100_probe
Code:
        INIT_WORK(&nic->tx_timeout_task,
                (void (*)(void *))e100_tx_timeout_task, netdev);

with this lines
Code:
#if !defined(__VMKLNX__)
        INIT_WORK(&nic->tx_timeout_task,
                (void (*)(void *))e100_tx_timeout_task, netdev);
#else
        INIT_WORK(&nic->tx_timeout_task,
                (void (*)(void *))e100_tx_timeout_task);
#endif

And the lines in function e100_io_error_detected
Code:
        netif_poll_enable(netdev);

with
Code:
#if CONFIG_E100_NAPI
        netif_poll_enable(netdev);
#endif


On the file kcompat.h I changed
Code:
#define INIT_WORK INIT_TQUEUE

for
Code:
#if !defined(__VMKLNX__)
    #define INIT_WORK INIT_TQUEUE
#endif


So far, the driver behaves well on esxi 5.0. Keep in mind it is a test driver, and to quote chilly: I provide them AS-IS and AT-YOUR-OWN-RISK


Attachments:
File comment: Driver for intel 8255x pro/100 family
net-e100-3.5.17.x86_64.vib.gz [547.09 KiB]
Downloaded 383 times
Fri Jun 14, 2013 10:35 am
Profile

Joined: Thu Jul 11, 2013 7:10 am
Posts: 8
Reply with quote
Post Re: Intel EtherExpress Pro 100+ [need driver]
I've just installed this vib, I'll let you know if I run into any issues :)


Fri Jul 12, 2013 5:28 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.