View unanswered posts | View active topics It is currently Fri Jul 21, 2017 4:45 pm



Reply to topic  [ 1 post ] 
 3ware RAID controller not visible to VM after VMDirectPath 
Author Message

Joined: Fri Nov 04, 2011 12:05 am
Posts: 1
Reply with quote
Post 3ware RAID controller not visible to VM after VMDirectPath
I want to enable direct access to my 3ware RAID controller from an Openfiler VM and hence have configured the 3ware RAID controller for passthrough in ESXi.

Details follow...

RAID controller: 3ware 9650SE-24M8 (Firmware: 4.10.00.024, BIOS: 4.08.00.0004)
ESXi version: Tried with both 4.1 and 5.0
VM OS: Openfiler v2.99

If I install Openfiler directly on the hardware (without ESXi), it recognises the RAID controller. I guess that rules out any issues with Openfiler.

Installing ESXi 4.1 or 5.0 on the hardware box and enabling passthrough for the RAID controller works as expected. But when I install Openfiler in a VM (with the PCI Device hardware pointing to the RAID controller), the Openfiler installer does show loading the 3ware driver (implying it could see the h/w) but the corresponding virtual drives (provisioned by the RAID controller) are not visible to the Openfiler installation! Remember the same virtual drives were visible to the Openfiler installation when Openfiler was being installed directly on the hardware.

Research on google shows people have had luck configuring passthrough for 3ware RAID controller (though not exactly the same model).

Am I missing something?

Rolf


Fri Nov 04, 2011 12:22 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.