View unanswered posts | View active topics It is currently Thu Nov 14, 2019 5:29 am

Reply to topic  [ 1 post ] 
 Radeon HD 5450 (1 GB DDR3 RAM) and passthrough 
Author Message

Joined: Wed Aug 10, 2011 6:32 am
Posts: 23
Reply with quote
Post Radeon HD 5450 (1 GB DDR3 RAM) and passthrough

I have added a Sapphire Radeon HD 5450 (1 GB DDR3 RAM) and set it up as PCIe passthrough device (with two entries, one for the graphics, one for the audio) on the guest OS (currently testing Windows XP Home 32-bit).

Then I installed the latest Catalyst driver and software package from Sapphire (are there newer versions directly from AMD/ ATI?):
Catalyst Control Center: 2011.0728.1723.29300
AMD Catalyst Installation Manager: 3.0.838.0
AMD Screen Driver: 8.881.0.0000
AMD APP SDK Runtime: 2.5.709.2

In the Windows guest display settings I now see three(!) desktops:
1: Intel GMA on-board graphics controller from my Intel DQ45CB mobo the host is running on
2+3: ATI Radeon HD 5450 Series - but both greyed out

The catalyst control center cannot be started. It tells me this:
Catalyst Control Center cannot be started because the currently active GPU is not supported

From the above described display settings I assume that currently only the Intel GMA is running, so I need to either switch it off and in parallel switch the ATI on, or I switch the ATI on, too, and let the Intel GMA still running. However, I have no clue which of these alternatives works and how to try it.
The problem is the following:
Once before I already had tried to adjust the display settings, but then the screen (extended desktop) went black and it was very hard to come back to the correct display, because I could not see the display settings controls anymore: Everything was just black, or the mouse cursor was on some not visible extended desktop? I do not know.
So does anybody have any recommendations how to proceed? Thank you!

I have fiddled some more with this, and after a restart I also got the well known ati2dvag bluescreen.

I had read that booting Windows in safe mode and then removing the old graphics card (the Intel GMA) form the list of the device manager (i.e. deactivating/ deinstalling that device) would help. However, when I boot in safe mode, the list of devices is competely empty. I read that this happens when the plug&play service is not running. However, in safe mode I cannot start that service, i.e. it tells me it cannot be started, because it depends on other services that are not running. When I click on the "dependencies" tab to see on which other services the non-running plug&play service depends, I again get the message that this cannot be shown, because it is not running. Stupid, isn't it?
So any more hints are very welcome. If this card does not work, I will need to give it back.
Also, it would be great of those guys for whom the HD 5450 worked would post in more details what they did (step by step), which versions of drivers they used, if they only passed through the graphics card or also the HDMI audio part of it etc. Thank you!

Kind regards,

MoBo: Intel DQ45CB (BIOS v129, VT-d enabled)
CPU: Intel Core 2 Duo E8400 FC-LGA4 "Wolfdale" (has VT-d) @ 3.00 GHz
HDD: 2x 1 TB Samsung Spinpoint F3 (in AHCI mode)

Virtu.: free vSphere Hypervisor (ESXi 4.1 U1)

Fri Aug 19, 2011 10:15 pm
Display posts from previous:  Sort by  
Reply to topic   [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.