View unanswered posts | View active topics It is currently Tue Aug 22, 2017 4:58 am



Reply to topic  [ 1 post ] 
 ZT Systems / MSI X58 Pro 
Author Message

Joined: Thu Jul 07, 2011 11:35 am
Posts: 1
Reply with quote
Post ZT Systems / MSI X58 Pro
2 years ago I bought a ZT Systems PC from Costco, of all great technology stores :P . At the time the price for a Core i7 and RAM in the box was better than building my own. With the added benefit of returning it ALL in 90-days should it dissatisfy me in the slightest way.

Well at the time, I tried to install esxi 3.5, but after spending about 2 days on it, I gave up and settled for using VMware Server 2 on Ubuntu. I used Server 2 till now with the stupid web page console crashing every 3 time I accessed it. Very Frustrating. But mostly my VM's were stable and I could do what I needed.

Last week, I started my search again, really looking to buy or build a new ESXi machine, BUT I found that the MSI X58 Pro MB was listed as compatible with 4.1, which is the MB inside my ZT Systems box. I bought 2 Intel Pro 1000 GT and installed ESXi 4.1 U1 on a 2 GB USB drive.

Specs
- MSI X58 Pro / 12 GB DDR3 1333 / NB:X58 Chipset SB:ICH10R
- Core i7-920 - LGA 1366
- BIOS AMI 8.15 03-19-2011
- Onboard NIC is not recognized
- Changes made to BIOS
Integrated Peripherals > On-Chip ATA Device > RAID Mode >> AHCI
Enabled: Intel Virtualization
Enabled: VT-d
- does the storage controller support RAID / battery backup for write cache: Unsure; how do I know?
- does the MB support Intel VT (vt-x): Yes, at the BIOS version above
- does it support vt-d (directed I/O): Yes

STEPS I took.
I did some stuff backwards, but it all worked out.
BEFORE I flashed the BIOS to 8.3, I was on 7.3 (4/17/2009) and did the following.

1. Change RAID Mode to AHCI - tried to install ESXi 4.1U1, but it failed. But 4.0 installed to Harddisk with out complaint.
2. Then decided to go with USB install. Reran the 4.0 install to USB and it installed fine.
3. Then tried to upgrade to 4.1U1, using the manual method I found here
http://suretalent.blogspot.com/2010/09/vmware-esxi-40-to-41-upgrade-how-to.html
This worked up until it said something like it found 2 ESXi installs and it did not like it, and reverted to the 4.0 on the next boot.
I figured it was the install on the harddrive. So... tred again. Used a partition CD to wipe the previous install on the harddisk and went back to Step 2.
4. Added 2 more Sata drives for datastores.
5. Migrated 2 VMs, and built 5 more from scratch.
6. Ran 5 VMs overnight - just let them sit and see if they'll crash or if the ESXi would crash. (I read someone else's post about not being able run more than 5 on a MSI X58)
7. In the morning, all VMs working, then decided to upgrade the BIOS because of VT-d support. Upgraded using a USB boot drive and the firmware from MSI's download page.
8. Booted the VM's and it seems to humming along fine for now.

Other Notes:
1. As far as Passthrough, I can see the USB Controllers, Firewire controller, the 2 Intel NICs, , Onboard (Realtek) NIC, Audio, Video.
What I don't see and would like is the IDE CD-ROM to show up. Is there a way to do this? (too cheap to buy a SATA DVD Drive $22; maybe later :D )

2. I used VEEAM FastSCP to transfer my VMs and iso images to the ESXi datastores (works great!)

3. VMWare Converter only worked for my MediaWiki appliance. For my windows 2k3 server, I had to use a manual conversion process found here.
http://knowtes.wordpress.com/2011/01/20/migrating-vms-from-vmware-server-to-esxi-without-vmware-converter/

Hope this helps someone.
Now on with the show.
Sam Park


Fri Jul 08, 2011 7:52 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.