View unanswered posts | View active topics It is currently Thu Dec 14, 2017 2:37 pm



Reply to topic  [ 1 post ] 
 Dell Optiplex 580 and ESXi4.1 update 1 
Author Message

Joined: Fri Apr 01, 2011 6:40 am
Posts: 1
Reply with quote
Post Dell Optiplex 580 and ESXi4.1 update 1
server / MB / NIC / controller make and model :
- Dell Optiplex 580 Stock standard Desktop model
- Box supports installation of Windows 2008 R2 (x64) install
- Box can be upgraded to 16GB Ram (as stated on Kingston RAM Site), has four DIMM slots, but currently only 4GB installed
CPU socket and type used :
- AMD Athlon II X2 B22 Processor
are the onboard NIC / storage controller working :
- Onboard Broadcom 5761 NIC did not recognise on default installation of ESXi4.1, added an Intel Pro 1000 (82541) PCI NIC before I performed the fix below which worked.
does the MB support Intel VT (vt-x) / AMD-V :
- AMD-V capable processor
any changes required to enable ESX/ESXi to recognize hardware components :
- Yes,
- Initial Build ESXi4.1 (Build 260247) to a 2GB SD Card in a USB adapter,
- installed the VMware ESX/ESXi 4.1 Driver CD for Broadcom NetXtreme II Ethernet Network Controllers, Broadcom still did not get picked up by ESXi
- upgraded to ESXi4.1 Update 1 (Build 348481) in an attempt to recognise onboard Broadcom NIC which it didn't again
- used
http://www.vm-help.com/esx40i/find_PCI_ID.php (lspci -v command in TSM) to output PCI ID of Broadcom NIC. PCI ID is 14e4:1681
- Used
viewtopic.php?p=3616#p3616
to verify that the driver would load and recognise Onboard Broadcom NIC
- Used
http://www.vm-help.com/esx40i/customize_oem_tgz.php
to rebuild my simple.map and oem.tgz files. NIC Description was already listed in pci.ids file.
simple.map line addition 14e4:1681 0000:0000 network tg3


BTW instead of :wq you can also use :x to save and close the file in vi. Those that have never used vi, press the insert key to edit the file first.
Might want to adjust the customize_oem_tgz page for people new to *nix systems and add in the press insert key to edit the file.


UPDATE: 2011-08-19
I was not able to get my Onboard Broadcom NIC to work properly on the network, even though the instructions worked and the NIC was recognised in the ESXi Network Adapters page. None of the VMs or ESXi system could communicate via this Broadcom hardware. In the End I bought a Dual Ethernet Intel Pro 1000 PT PCIe and added it with my Intel Pro 1000 PCI card for three working ethernet ports.

With the CPU (AMD Athlon II X2 B22 Processor) I could not install Nested VMs on my VM ESXi Cluster hosted on top of the physical ESXi installation.

I currently have 16GB RAM installed on this box, but only 4GB is recognised in the BIOS for some reason. I'm not worried as ESXi boots and detects about 15.7GB anyway, so I am able to utilise all this RAM for all my hosted VMs.

I have added an additional 1TB SATA disk and connected the SATA DVD Drive. My current Storage capacity is now a 320GB SATA disk (VMFS01) and a 1TB SATA disk (VMFS02).


Fri Apr 01, 2011 7:12 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.