View unanswered posts | View active topics It is currently Thu Aug 17, 2017 1:26 pm



Reply to topic  [ 5 posts ] 
 Asrock AliveNF6G-GLAN (Nvidia MCP61) 
Author Message

Joined: Tue Apr 14, 2009 3:47 am
Posts: 24
Reply with quote
Post Asrock AliveNF6G-GLAN (Nvidia MCP61)
Just upgraded my setup from ESXi 3.5u4 to 4.0:
- Asrock AliveNF6G-GLAN (Nvidia MCP61 chipset)
- AMD Athlon X2 4850e
- 8 GB DDR800
- intel pro 1000 MT nic

Running from USB-stick

I was glas to see the onboard sata controller works out-of-the-box with 4.0 and also the onboard PATA is recognised and listed. Haven't tested out the PATA controller with disks though, have none lying around anymore. With 3.5u4 the onboard SATA controller needed an edit in oem.tgz as well as an alternate (older) nv_sata.o module.

The onboard nic however needed an edit in the oem.tgz (10de:03ef, also documented elsewhere in this forum. The nic is already listed in pci.ids though). This hasn't changed from 3.5u4.

The intel nic did not require any modification to be supported, just as in 3.5u4.


Mon Jun 01, 2009 12:52 am
Profile

Joined: Tue Apr 14, 2009 3:47 am
Posts: 24
Reply with quote
Post Re: Asrock AliveNF6G-GLAN (Nvidia MCP61)
My upgrade process:

A few thoughts
- I knew the onboard nic would not be detected after the upgrade without a modified oem.tgz
- My ESXi box does not have a monitor or keyboard attached
- I did not want to have to move the ESXi box to my computerroom to do the upgrading. It is stowed away nicely somewhere far in the attic and physically difficult to reach

Idea, will it work?
- I decided to try to include the modified oem.tgz in the downloadable upgrade package (ESXi-4.0.0-0.4.164009-upgrade-release.zip) from VMware and upgrade the host like in these instructions here: http://www.vm-help.com/esx40i/ESXi40_upgrade_without_virtualcenter.php
- I used the original oem.tgz files uploaded by Dave from here: http://www.vm-help.com/forum/viewtopic.php?f=14&t=214 and modified the simple.map with an entry for the onboard nic (10de:03ef). Packed it into oem.tgz with the required directory structure (etc\vmware\)
- replaced the (empty) oem.tgz in the VMware-image.tar.gz in the zip-package with the new one. The tricky part is you have to also update the checksum.md5 file in the VMware-image.tar.gz with the new md5-hash of the new oem.tgz file
- updated the zip-package with the modified VMware-image.tar.gz and checksum.md5 file
- modified the checksum.md5 file in the zip-package with the new md5-hash of the modified VMware-image.tar.gz

EDIT
The modifying was done in Ubuntu 9.04. The modifying needs to be done in a Linux environment, something to do with the access rights of the files (copied the zip-package to my Ubuntu installation). The update was done from a Windows XP machine (copied the modified zip-package back to the Windows XP machine).
END EDIT

And... it worked. The VSphere Host Update Utilty didn't complain about a corrupt .zip package and let me do the update. Just to be safe I upgraded the host via the intel pro 1000 MT nic connection (both nic have a VMKernel port attached for management). The upgrade process took quite some time, especially after the reboot the upgrade process seemed to stop, just like Dave documented: But just be patient, it will go through eventually.


Last edited by dhrto on Mon Jun 01, 2009 2:12 am, edited 2 times in total.



Mon Jun 01, 2009 1:18 am
Profile

Joined: Tue Apr 14, 2009 3:47 am
Posts: 24
Reply with quote
Post Re: Asrock AliveNF6G-GLAN (Nvidia MCP61)
One thing I haven't figured out yet, when I go to the confuration tab > hardware > processors it says:
- Power Management Technoloy = Not Available
- Power Management Policy = off

ESXi 4.0 is supposed to support AMD PowerNow!, one of the reasons I was eager to upgrade (have 2 similar boxes running and any power savings is welcome). This feature is also enabled in my bios (Cool'n'Quiet). I there something else I need to check/do for support of the feature?


Mon Jun 01, 2009 1:23 am
Profile

Joined: Wed Mar 18, 2009 1:32 pm
Posts: 455
Location: Sweden
Reply with quote
Post Re: Asrock AliveNF6G-GLAN (Nvidia MCP61)
Ops , I didn't read the was after installation

_________________
Dovie'andi se tovya sagain,



Mon Jun 01, 2009 8:03 pm
Profile WWW

Joined: Tue Jun 02, 2009 1:41 pm
Posts: 1
Reply with quote
Post Re: Asrock AliveNF6G-GLAN (Nvidia MCP61)
question closed
forgot the nic for lvm driver


Tue Jun 02, 2009 1:47 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.