View unanswered posts | View active topics It is currently Wed Dec 13, 2017 8:09 pm



Reply to topic  [ 1 post ] 
 Working:Gigabyte GA-M61PME-S2, Sempron LE1300, Netgear GA311 
Author Message

Joined: Fri Jan 01, 2010 4:59 pm
Posts: 30
Reply with quote
Post Working:Gigabyte GA-M61PME-S2, Sempron LE1300, Netgear GA311
I’ve seen that some have posted that they couldn’t get the Netgear GA311 card working with ESXi (this is a fairly low-end retail gigabit network card). I have found that the (attached) oem.tgz file seems to work with this card; I can’t remember where I sourced this file from but I have found that it worked, if anyone can identify the file’s author please let me know so I can credit their work.

My brief was to build the system using some rather old, rather odd hardware on a very basic (low power and low performance) AMD Sempron LE1300 processor (probably barely enough to get ESXI to start). ESXi 3.5 stuck its nose up at the board but I was rather surprised when ESXi 4.0 worked out of the box, with all but the network card (after adding this oem.tgz). Spec was:


Motherboard: Gigabyte GA-M61PME-S2 (running an nForce 430 chipset)
CPU: AMD Sempron LE1300 (a 64 bit, single-core low power chip at the low end of their range)
Network card: Netgear GA311 Rev A1 (based on a Realtek RTL8169S-32) Gigabit PCI card
HDD: Two sata drives (160gig WD and 1tb green drive)
RAM: 2x2gig (total of 4gig of ram, less 32mb for video ram segment)

This Netgear GA311 card is based on the Realtek 8169 chipset and I tried a few drivers with it but the attached one was the only one that played ball.

I’ve usually only used whitelist Intel NICs before so I was a little new to the process; I used this method (somewhat convoluted but it worked):

- copied ESXi image and the oem.tgz to a Ubuntu box with SSH;
- modified the iso file with Iso Master
- copied this back to the main system to burn to disc (installed and booted with that)
- downloaded slax for USB key (http://www.slax.org/) and configured that to boot from USB
- copied the oem.tgz file to the key
- installed ESXi 4.0 using the modified disc (it picked up the oem.tgz file well)
- booted with the slax key and coped the oem.tgz file over to the hypervisor1 partition (overwriting the near-empty one)
- restarted and it worked.

I didn’t bother with the dd update as I didn’t think I’d be doing this any more frequently.

The machine’s only running some low level activity (a VM to download large files uninterrupted, some basic SQL serving, experimental builds of new Linux distros, etc.) and I am surprised at how well the Sempron is coping with the load.


Attachments:
File comment: R8169 supprting oem.tgz file that worked with Netgear GA311 Gigabit NIC
oem.tgz [25.01 KiB]
Downloaded 320 times
Mon May 10, 2010 2:42 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.