View unanswered posts | View active topics It is currently Sun Dec 16, 2018 7:21 am



Reply to topic  [ 4 posts ] 
 Adding simple.map to OEM.TGZ, won't boot 
Author Message

Joined: Wed Aug 11, 2010 3:14 pm
Posts: 4
Reply with quote
Post Adding simple.map to OEM.TGZ, won't boot
I've been trying to get a RealTek 8169 NIC to work on an existing ESXi 4.1 machine, have read dozens of posts, and can't find a single post or thread with complete and clear instructions that work. Was able to get it to work by putting r8169.o in oem.tgz (no one mentioned it has to be in a specific directory structure within the archive, otherwise ESXi crashes on boot), then making the required entry in simple.map (the actual one, not in oem.tgz), and loading the module manually.

However, on reboot, the changes in simple.map are lost and the driver does not load. So, I put the modified simple.map in oem.tgz (in /etc/vmware), and that causes ESXi to crash on boot (boot image corrupted).

What am I missing???


Wed Aug 11, 2010 3:31 pm
Profile
Site Admin

Joined: Mon Mar 16, 2009 10:13 pm
Posts: 3880
Reply with quote
Post Re: Adding simple.map to OEM.TGZ, won't boot
Quote:
However, on reboot, the changes in simple.map are lost and the driver does not load. So, I put the modified simple.map in oem.tgz (in /etc/vmware), and that causes ESXi to crash on boot (boot image corrupted).


Are you creating the oem.tgz file on a Linux or ESXi system?

_________________
Dave Mishchenko
VMware vExpert 2009-2013
Image
Now available - VMware ESXi: Planning, Implementation, and Security
Also available - vSphere Quick Start Guide


Wed Aug 11, 2010 9:49 pm
Profile

Joined: Wed Aug 11, 2010 3:14 pm
Posts: 4
Reply with quote
Post Re: Adding simple.map to OEM.TGZ, won't boot
That actually hit me yesterday, and that was the issue, I was modifying the tgz locally on a Windows system using 7zip, and I guess ESXi didn't quite like the .tgz format employed by 7zip (thought it was an open standard...). Thanks anyway, all seems to be working well now when creating the .tgz inside of ESXi.


Thu Aug 12, 2010 3:43 am
Profile

Joined: Wed Mar 18, 2009 1:32 pm
Posts: 455
Location: Sweden
Reply with quote
Post Re: Adding simple.map to OEM.TGZ, won't boot
Windows can't handle Linux file permissions

_________________
Dovie'andi se tovya sagain,



Thu Aug 12, 2010 3:46 am
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.