View unanswered posts | View active topics It is currently Mon Oct 14, 2019 2:47 am



Reply to topic  [ 10 posts ] 
 unable to load module vmfs3 
Author Message

Joined: Fri Sep 17, 2010 8:17 pm
Posts: 7
Reply with quote
Post unable to load module vmfs3
Hi there,

I have used Dave Mishchenko mymod-network.new2.tgz and rename it to oem.tgz and then copy it into my esxi 4.1 usb installation. I have also appended these 2 files (syslinux.cfg, and isolinux.cfg) wiht ' --- oem.tgz'. I have also copied oem.tgz into imagedd.bz2. I run the installation and it stop with the error message "vmkctl.HostCtlException: Unable to load module /usr/lib/vmware/vmkmod/vmfs3: Failure". Any idea what's wrong? Or what have I done wrong? Thank in advance.


Sat Oct 02, 2010 3:46 am
Profile
Site Admin

Joined: Mon Mar 16, 2009 10:13 pm
Posts: 3880
Reply with quote
Post Re: unable to load module vmfs3
The error indicates that a NIC was not initialized. What sort of MB / server are you using and what model of NIC does it have? Press ALT+F1 after the error and login if required with root (password is blank). Run lspci -p and record the PCI id of the NIC and see if a module is listed for it. You can also use lspci to identify the NIC model. If the output scrolls to much append | less to the commands.

_________________
Dave Mishchenko
VMware vExpert 2009-2013
Image
Now available - VMware ESXi: Planning, Implementation, and Security
Also available - vSphere Quick Start Guide


Sat Oct 02, 2010 2:49 pm
Profile

Joined: Fri Sep 17, 2010 8:17 pm
Posts: 7
Reply with quote
Post Re: unable to load module vmfs3
Hi Dave,
Thank you for you respond. My MB is ASUS P6X58D Premium and NIC is Marvell Yukon 88E8056 (Vendor Id 11AB and Dev Id 4364). The following is snippet list of lspci -p

000:005:00.0 11ab:4364 1043:81f8 15/ 15/0x98 A V
000:006:00.0 11ab:4364 1043:81f8 11/ 11/0x78 A V

It looks that NIC drive is loaded and initialized successfully. What might be wrong?


Sat Oct 02, 2010 6:24 pm
Profile
Site Admin

Joined: Mon Mar 16, 2009 10:13 pm
Posts: 3880
Reply with quote
Post Re: unable to load module vmfs3
ESXi doesn't ship with a yukon driver. You can try the one here - http://www.vm-help.com/esx40i/customize_oem_tgz.php. Look at the Customizing OEM forum for a script to create a custom install image.

_________________
Dave Mishchenko
VMware vExpert 2009-2013
Image
Now available - VMware ESXi: Planning, Implementation, and Security
Also available - vSphere Quick Start Guide


Sat Oct 02, 2010 6:27 pm
Profile

Joined: Fri Sep 17, 2010 8:17 pm
Posts: 7
Reply with quote
Post Re: unable to load module vmfs3
Hi Dave,

I have found something interesting. I run esxcfg-nics -l and it show me blank list and I tried to load sky2.o driver from /usr/lib/vmare/vmkod using this command vmkload_mod sky2.o and it said module sky2.o loaded successfully and I tried again to execute esxcfg-nics -l and it show the NIC Marvell Yukon. So I think the driver is not load even I have added the oem.tgz onto the root as well as in imagedd.bz2. Any idea?


Sat Oct 02, 2010 6:34 pm
Profile
Site Admin

Joined: Mon Mar 16, 2009 10:13 pm
Posts: 3880
Reply with quote
Post Re: unable to load module vmfs3
If it loads Ok manually then you should check simple.map to ensure that the PCI id for your NIC is listed.

_________________
Dave Mishchenko
VMware vExpert 2009-2013
Image
Now available - VMware ESXi: Planning, Implementation, and Security
Also available - vSphere Quick Start Guide


Sat Oct 02, 2010 6:52 pm
Profile

Joined: Fri Sep 17, 2010 8:17 pm
Posts: 7
Reply with quote
Post Re: unable to load module vmfs3
Hi Dave,

You are right, there is a typo mistake in simple.map. I am going to try it again.


Sat Oct 02, 2010 7:28 pm
Profile

Joined: Wed Nov 03, 2010 7:08 am
Posts: 1
Reply with quote
Post Re: unable to load module vmfs3
I had same problem. I try install custom ESXi 4.1 with this guide
viewtopic.php?f=12&t=4

I Have realtek 8169SC nic.
lspci -v show
000:006:00.0 ethernet controller network controller: Realtek Semiconductor Co., Ltd. RTL-8110SC/8169SC Gigabit Ethernet
Class 0200: 10ec:8167

lspci -p
000:006:00.0 10ec:8167 147b:1082 11 / 11/0xc0 A V

i download somewhere here 8169 driver package. I run esxcfg-nics -l and it show me blank list.


Wed Nov 03, 2010 7:35 am
Profile
Site Admin

Joined: Mon Mar 16, 2009 10:13 pm
Posts: 3880
Reply with quote
Post Re: unable to load module vmfs3
I would take a look through /var/log/messages to see if the driver was loaded and if so if it was able to recognize any devices.

You can also try to load the driver manually with vmkload_mod /usr/lib/vmware/vmkmod/<drivername>

_________________
Dave Mishchenko
VMware vExpert 2009-2013
Image
Now available - VMware ESXi: Planning, Implementation, and Security
Also available - vSphere Quick Start Guide


Wed Nov 03, 2010 10:03 am
Profile

Joined: Sat Dec 11, 2010 4:32 pm
Posts: 1
Reply with quote
Post Re: unable to load module vmfs3
Hi,

Was the type the Dev ID i.e. 4362 instead of 4364?

I have the same MOBO P6X58D-E and I am also trying to install ESXi 4.1. Did you have to make any other changes aside for simple.map?
Did you have to you have to make changes for the new sky2.o driver to load automatically?

bluei_man wrote:
Hi Dave,

You are right, there is a typo mistake in simple.map. I am going to try it again.


Sun Dec 12, 2010 4:15 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 10 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.