View unanswered posts | View active topics It is currently Wed Oct 16, 2019 4:43 am



Reply to topic  [ 6 posts ] 
 SOLVED: error umounting esx-5 using emkesxiaio_4.2.sh 
Author Message

Joined: Tue May 03, 2011 11:37 am
Posts: 5
Reply with quote
Post SOLVED: error umounting esx-5 using emkesxiaio_4.2.sh
I am using th emkesxiaio_4.2.sh script and getting the following:

umount: /mnt/vmware/esx-5: device is busy

I get this right after it copies the esx-build/oem.tgz to esx-5/oem.tgz. This a fresh install of ubuntu on a hard drive.

Any ideas?


Last edited by furian on Fri May 06, 2011 5:31 pm, edited 1 time in total.



Tue May 03, 2011 11:42 am
Profile

Joined: Wed Mar 18, 2009 1:32 pm
Posts: 455
Location: Sweden
Reply with quote
Post Re: error umounting esx-5 when using the emkesxiaio_4.2.sh s
furian wrote:
I am using th emkesxiaio_4.2.sh script and getting the following:

umount: /mnt/vmware/esx-5: device is busy

I get this right after it copies the esx-build/oem.tgz to esx-5/oem.tgz. This a fresh install of ubuntu on a hard drive.

Any ideas?



Can you please test mkesxiaio_4.3.sh script I uploaded today ?

a bug that I haven't seen before. added a delay to the unmount parts of the script

_________________
Dovie'andi se tovya sagain,



Tue May 03, 2011 8:12 pm
Profile WWW

Joined: Tue May 03, 2011 11:37 am
Posts: 5
Reply with quote
Post Re: error umounting esx-5 when using the emkesxiaio_4.2.sh s
I rebuilt using fedora and now it seems to be working. I'm building the iso as I'm typing this... oh its just finished :) I will reload ubuntu later, try with the script i downloaded yesterday to see if I can duplicate, then try the new one. I will let you know how that works out.


Wed May 04, 2011 1:48 pm
Profile

Joined: Tue May 03, 2011 11:37 am
Posts: 5
Reply with quote
Post Re: error umounting esx-5 when using the emkesxiaio_4.2.sh s
I reloaded ubuntu and was able to duplicate the error with 4.2, but I'm getting this with the new script, immediately after running.

./mkesxiaio_4.3.sh: line 385: syntax error near unexpected token `{#'
./mkesxiaio_4.3.sh: line 385: `func_add_custom_files(){# Add custom files from the custom-esx dir, '


Wed May 04, 2011 5:08 pm
Profile

Joined: Wed Mar 18, 2009 1:32 pm
Posts: 455
Location: Sweden
Reply with quote
Post Re: error umounting esx-5 when using the emkesxiaio_4.2.sh s
Ops, add a space or TAB after the { and try again
Updating the script

_________________
Dovie'andi se tovya sagain,



Thu May 05, 2011 12:25 am
Profile WWW

Joined: Tue May 03, 2011 11:37 am
Posts: 5
Reply with quote
Post Re: error umounting esx-5 when using the emkesxiaio_4.2.sh s
That did it!! Thanks for the quick turn around.


Fri May 06, 2011 5:29 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.