View unanswered posts | View active topics It is currently Mon Oct 14, 2019 5:25 pm



Reply to topic  [ 8 posts ] 
 problem adding highpoint 222x support 
Author Message

Joined: Sat Oct 23, 2010 5:09 am
Posts: 18
Reply with quote
Post problem adding highpoint 222x support
Hi,

I have a highpoint 222x controller card. According to http://www.vm-help.com/esx40i/customize_oem_tgz.php this card would have support but it needs to be added to oem.tgz. I tried with this oem.tgz (linked) http://www.bytedynamix.com/?p=93 but no luck.

Im kinda green in the oem.tgz apartment and cant figure out how to do this. Is there a oem.tgz file with the right pci ids anywhere ?? :)

88sx6081 (11AB:6081) - HighPoint RocketRAID 2220


Thu Mar 24, 2011 10:42 pm
Profile
Site Admin

Joined: Mon Mar 16, 2009 10:13 pm
Posts: 3880
Reply with quote
Post Re: problem adding highpoint 222x support
Have you built an ISO image with it? If so, do you see the driver in /usr/lib/vmware/vmkmod/? If it's there then try to load it manually with vmkload_mod <drivername>. Run lspci -p to see if tha vmhbax entry exists for it and fdisk -l should show a disk. If it doesn't then the driver is the issue and not the oem.tgz file.

_________________
Dave Mishchenko
VMware vExpert 2009-2013
Image
Now available - VMware ESXi: Planning, Implementation, and Security
Also available - vSphere Quick Start Guide


Thu Mar 24, 2011 11:01 pm
Profile

Joined: Sat Oct 23, 2010 5:09 am
Posts: 18
Reply with quote
Post Re: problem adding highpoint 222x support
the driver should be in : sata_mv.o But after i load it i cant find any disks with fdisk -l command.
I cant see the pci id with lspci -l either. So i need a "new" driver for this.

I cant see whats the differance from sample.map / oem.tgz / vmkmod. Where is the driver ?

sorry for all newbie questions. Im in a learning proccess :)


Fri Mar 25, 2011 2:31 am
Profile
Site Admin

Joined: Mon Mar 16, 2009 10:13 pm
Posts: 3880
Reply with quote
Post Re: problem adding highpoint 222x support
Should the controller be using the sata_mv.o driver or sata_sil24.o?

_________________
Dave Mishchenko
VMware vExpert 2009-2013
Image
Now available - VMware ESXi: Planning, Implementation, and Security
Also available - vSphere Quick Start Guide


Fri Mar 25, 2011 10:37 pm
Profile

Joined: Sat Oct 23, 2010 5:09 am
Posts: 18
Reply with quote
Post Re: problem adding highpoint 222x support
Think it should be the SATA_mv.o driver. Is there a way to check where the pci id for hihighpoint controller is?


Sun Mar 27, 2011 7:44 am
Profile
Site Admin

Joined: Mon Mar 16, 2009 10:13 pm
Posts: 3880
Reply with quote
Post Re: problem adding highpoint 222x support
You can do a search on the Linux driver for the controller or download it from Highpoint's web site.

_________________
Dave Mishchenko
VMware vExpert 2009-2013
Image
Now available - VMware ESXi: Planning, Implementation, and Security
Also available - vSphere Quick Start Guide


Sun Mar 27, 2011 4:18 pm
Profile

Joined: Thu Jul 15, 2010 12:06 pm
Posts: 2
Reply with quote
Post Re: problem adding highpoint 222x support
I have the exact same problem as 2inzane4u. My oem.tgz seems to be installed correctly, i can find and manually load the driver from /usr/lib/vmware/vmkmod without any problems.
lspci -v:
Code:
000:001:00.0 SCSI storage controller Mass storage controller: Galileo Technology Ltd. MV88SX6081 8-port SATA II PCI-X Controller Class 0100: 11ab:6081

Still the drives connected to the raidcard can't be found.. and no.. no drives are found with fdisk -l

Any suggestions?


Sun Jun 12, 2011 8:17 am
Profile
Site Admin

Joined: Mon Mar 16, 2009 10:13 pm
Posts: 3880
Reply with quote
Post Re: problem adding highpoint 222x support
dexxa wrote:
I have the exact same problem as 2inzane4u. My oem.tgz seems to be installed correctly, i can find and manually load the driver from /usr/lib/vmware/vmkmod without any problems.
lspci -v:
Code:
000:001:00.0 SCSI storage controller Mass storage controller: Galileo Technology Ltd. MV88SX6081 8-port SATA II PCI-X Controller Class 0100: 11ab:6081

Still the drives connected to the raidcard can't be found.. and no.. no drives are found with fdisk -l

Any suggestions?

If you run lspci -p is the module listed for the controller?

_________________
Dave Mishchenko
VMware vExpert 2009-2013
Image
Now available - VMware ESXi: Planning, Implementation, and Security
Also available - vSphere Quick Start Guide


Sun Jun 12, 2011 5:59 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 8 posts ] 

Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.