View unanswered posts | View active topics It is currently Sat Sep 22, 2018 8:28 pm



Reply to topic  [ 113 posts ]  Go to page Previous  1 ... 7, 8, 9, 10, 11, 12  Next
 RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4 
Author Message

Joined: Thu Apr 07, 2011 1:53 am
Posts: 6
Reply with quote
Post Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4
I follow with interest the forum and I solved my whitebox installation.
I'm using a ASUS P7P55D mobo and the Intel AHCI internal SATA controller. This mb has onboard a Realtek NIC (10ec:8168) PCI chip.
Everithing works fine with the driver found here on the forum, but at the end I've bought a PCI-X Intel dual port board PCI/1000PT for VM network (it's working fine at 1000MB).
I'm using realtek port just for maintnance port. This port wan't start at 1000MB, it just work (quite well) at 100MB. I've atteched to 3 different high level switches (procurve and 3com) and I didn't find a way to let this realtek port to work at 1GB. In any case I really suggest the expense for a good 1gb net card (Intel e.g.).

Dome


Mon Apr 11, 2011 2:54 am
Profile

Joined: Thu Feb 17, 2011 9:12 am
Posts: 40
Reply with quote
Post Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4
hi i saw the topic here and yes i am playing arround with the same onboard nic ( XPC SH55J2 shuttle), tried a lot already and the one from frutis is the best for this moment( i cannot get this driver in MTU9000....also strange.....it is stable and working BUT... it shows in ESXi 4.1 1000MB full duplex. when i look in my switch ( SRW2016 ) it show a 100MB connection. i saw this when i tried to put all 3 nics into LAG. the intel e1000 are connected 1000MB in the cisco... and the RTL8111E is only connected 100MB in the cisco.

-> is it a driver problem? i would think so...

-> are there more people with the same problem?

googleing arround.. i found on a linux forum they were talking about use R8168 driver for the RTL8111E nic and NOT the R8169. that is not good. the one from frutis is R8169. i know esxi is NOT linux but could it make sense..

What is the VendorID for this nic


Mon Apr 11, 2011 7:54 am
Profile

Joined: Thu Apr 07, 2011 1:53 am
Posts: 6
Reply with quote
Post Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4
I've tried both driver, r8168 and r8169. They both work fine at 100mb but no way to get 1gb speed. And yes, my vShere center tells speed at 1000Mb, but it's not true.
I found other r8168 (v8.018) driver in the forum but I've not yet tested.
My lspci -v say vendorid 10ec:8168.
In any case I'm using this realtek card only for the maintnance net, the vms have assigned the e1000 (dual port) without any issue.

Thanks


Mon Apr 11, 2011 8:38 am
Profile

Joined: Thu Apr 21, 2011 5:20 am
Posts: 1
Reply with quote
Post Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4
BinaryBandit,
Can you post exactly what you did - I have the same board and am just starting to figure out how to get esxi to run
Thanks,
Glen


Thu Apr 21, 2011 10:29 am
Profile

Joined: Thu Feb 17, 2011 9:12 am
Posts: 40
Reply with quote
Post Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4
hi yes that one shoudl work 1000MBps Full duplex the R8168 and yes that show 1000 in my switch and i can lacp them with other cards at 1000.
took a quick look R8168 Driver 8.018.00


Tue May 03, 2011 9:40 am
Profile

Joined: Sun May 29, 2011 3:17 am
Posts: 1
Reply with quote
Post Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4
I experienced various issues with the realtek 8168 chip with my onboard and pci-e nics. e1000 interfaces failed completely (in windows vm's), whilst vmxnet3 adapters appeared to work I experienced some dropouts. I have Untangle in a VM as a gateway and accessing certain sites/pages caused parts of the pages never to load (bbc iplayer, some parts of the bbc news site). I could still access other sites though so this wan't a driver crash - more that it would give up. Odly, removing some of the network traffic processing of Untangle (traffic scanning) appeared to resolve the issue sometimes.

I tried various flavours of the 8168 driver posted on this forum and found that the issue existed with all of them. I instead added the r8169.o from here http://www.vm-help.com/forum/viewtopic.php?f=12&p=7412#p7412 and edited simple map and everything works perfectly :-)

System:
mobo:GA-MA770T-UD3
TP-Link PCI-e Gbit Nics
ESXi 4.1.0 build 381591


Sun May 29, 2011 7:35 am
Profile

Joined: Thu Apr 15, 2010 3:22 pm
Posts: 2
Reply with quote
Post Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4
Hello,
Is someone use this custom oem.tgz for the intel D510MO MB ?
This MB has internal RTL8111/8168 NIC and i don't know if it's work with esxi4.1...

Thanks


Wed Jun 01, 2011 2:46 am
Profile

Joined: Fri Jun 17, 2011 4:35 am
Posts: 43
Reply with quote
Post Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4
can sombody send me a copy of esxi.iso after adding RTL8111/8168 to it coz i need it urgently and i faild to do it by myself its very difficult i couldnt undrestand the explanation of dave and scripts

thanks in advance


Mon Jun 20, 2011 2:09 pm
Profile

Joined: Sat Jul 02, 2011 7:52 am
Posts: 1
Reply with quote
Post Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4
Does this oem.tgz support using the sata controller for passthrough?


Sat Jul 02, 2011 7:57 am
Profile

Joined: Thu Jul 14, 2011 10:51 pm
Posts: 2
Reply with quote
Post Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4
I think I am missing something, but can't figure it out.

I have a Gigabyte GA-P55A-UD6 and can not get the SATA AHCI or Realtek 8168 to work. The NIC is obviously not working as it comes up and states there is no network card installed. I'm assuming the SATA is not working either as I do not have a /bootbank directory and none of the changes I make are there after a reboot.

I have tried several oem.tgz files, which I would think would make one of the two work, but I haven't had any luck with either device.

Thank you in advance!


Thu Jul 14, 2011 10:56 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 113 posts ]  Go to page Previous  1 ... 7, 8, 9, 10, 11, 12  Next

Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.