temp.vm-help.com
http://www.vm-help.com/forum/

RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4
http://www.vm-help.com/forum/viewtopic.php?f=12&t=1272
Page 6 of 12

Author:  tucemiux [ Mon Aug 09, 2010 12:02 pm ]
Post subject:  Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4

I'm using this NIC:

Realtek 8111DL

This is the motherboard I have:

http://www.newegg.com/Product/Product.a ... 6813130254

I created an ISO with the drivers I found on this post. I was able to install ESXi on a hard drive, I have a data store but the network connection to the ESXi box goes down after 5~10 minutes. I guess the driver wasn't meant to be used with my NIC? Or maybe it's unstable for everyone?

Can someone please let me know what is the case? I'm seeing some people say it works for them, others say it doesnt. It works on my machine but then the NIC fails. I'm trying to figure out if there is something I can do, updating the drivers or what not??? or maybe I'm going to have to get a supported NIC.

Author:  Dave.Mishchenko [ Mon Aug 09, 2010 3:57 pm ]
Post subject:  Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4

Quote:
I have a data store but the network connection to the ESXi box goes down after 5~10 minutes. I guess the driver wasn't meant to be used with my NIC? Or maybe it's unstable for everyone?

Can someone please let me know what is the case? I'm seeing some people say it works for them, others say it doesnt. It works on my machine but then the NIC fails. I'm trying to figure out if there is something I can do, updating the drivers or what not??? or maybe I'm going to have to get a supported NIC.


With ESXi going down is it the host that is unresponsive or virtual machine? If VMs then what kind are you running and does the host stay stable if no VMs run?

A quick fix is an Intel Pro1000GT. You might also want to check the source that would used to build the driver and see if anything newer exists for your NIC.

Author:  tucemiux [ Tue Aug 10, 2010 4:09 pm ]
Post subject:  Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4

I guess I wasn't that clear.

ESXi's network goes down for some reason. My box is not reachable, I am unable to ping it and the network tests that I run on ESXi fail. I attempt to renew the network -- it doesnt work, I configure a new IP -- it doesn't work. I need to reboot the machine before I am able to connect to it again using vSphere.

I have done more tests and it looks like it's with Windows 2008 that is making the box cry. I just installed and updated ubuntu server and had no issues. It looks like the only problem is with Windows 2008 but I would need to test it some more days to see if that is the case.

I ordered an Intel NIC just in case though. With windows 2008 the connection is slow using vSphere. The NIC does work except it works kind of flaky with Windows 2008.

Author:  Dave.Mishchenko [ Tue Aug 10, 2010 4:55 pm ]
Post subject:  Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4

Try a different virtual NIC type in the VM. It seems similar to this problem with w2k3 - viewtopic.php?f=12&t=2319.

Author:  angeld111 [ Wed Aug 11, 2010 3:39 pm ]
Post subject:  Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4

Chilluminati wrote:
Just had the same issues (network connection broke) with this 8168 driver. As frutis mentioned above, the 8169 driver works like a charm :)

Just download the zip file there, rename the file 8169 to 8169.o and update simple-map (10ec:8168 0000:0000 network r8169.o). Put this stuff into oem.tgz and upload.


When I put simple.map in oem.tgz, get a PSOD on reboot (ESXi 4.1)

Author:  angeld111 [ Thu Aug 12, 2010 3:45 am ]
Post subject:  Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4

angeld111 wrote:
Chilluminati wrote:
Just had the same issues (network connection broke) with this 8168 driver. As frutis mentioned above, the 8169 driver works like a charm :)

Just download the zip file there, rename the file 8169 to 8169.o and update simple-map (10ec:8168 0000:0000 network r8169.o). Put this stuff into oem.tgz and upload.


When I put simple.map in oem.tgz, get a PSOD on reboot (ESXi 4.1)


Resolved, issue was creating tgz on a Windows system, ESXi did not like the format. Creating tgz inside ESXi resolved issue.

Author:  kill3r [ Sun Oct 17, 2010 12:14 pm ]
Post subject:  Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4

Hi

Is it possible to gat a download link for a ISO with the Realtek mod please? :D

Thanks in advance

Author:  keith.bucknall [ Sat Oct 30, 2010 5:48 am ]
Post subject:  Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4

Hi there, I have just purchased a Shuttle SH55J2 which has a Realtek RTL 8111E NIC, simply (as I am new to ESXI and Linux) what is the best driver to use and how do i create the oem.tgz to use with esx 4.1 running from a USB 1GB flash drive.

thanks

Author:  keith.bucknall [ Sat Oct 30, 2010 7:34 am ]
Post subject:  Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4

Hi all, I have managed to inject the oem.tgz file onto the image.dd and burn onto the USB, the driver is working ok, but when i look at the config through the vmware client, under networking it states that vmnic0 is discounted - however i can clearly connect it to.

Has anyone else seen this issue?

Author:  skanan [ Thu Nov 04, 2010 12:21 pm ]
Post subject:  Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4

FYI. I have tried 2 versions of r8168.o. Non of them work well with
Gateway AMD machine with realtek chip on board using esx4.1i. /var/log/messages showed the assert error in driver module.

Page 6 of 12 All times are UTC - 8 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/