View unanswered posts | View active topics It is currently Sun Apr 30, 2017 10:22 pm



Reply to topic  [ 113 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6, 7 ... 12  Next
 RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4 
Author Message

Joined: Sat Dec 12, 2009 8:28 am
Posts: 1
Reply with quote
Post Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4
Just had the same issues (network connection broke) with this 8168 driver. As frutis mentioned above, the 8169 driver works like a charm :)

Just download the zip file there, rename the file 8169 to 8169.o and update simple-map (10ec:8168 0000:0000 network r8169.o). Put this stuff into oem.tgz and upload.

Mainboard: Asrock ALiveXFire-eSATA2 R3.0

Hint: to use the onboard sb600 sata-controller add "1002:4380 0000:0000 storage ahci" to simple.map, after setting the controller to ahci mode in bios.


Sat Dec 12, 2009 8:37 am
Profile

Joined: Sat May 16, 2009 1:06 am
Posts: 5
Reply with quote
Post Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4
Thanks so much for your driver. It works on my computer for the GA-P55A-UDR3 motherboard. However, I have to change the driver controler mode in the BIOS settings to AHCI and manually copy the oem file to the Hypervisor 1 partition.

Again, thanks so much!


Fri Jan 01, 2010 9:38 pm
Profile

Joined: Tue Dec 29, 2009 2:34 pm
Posts: 1
Reply with quote
Post Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4
Being able to refer to these posts served to be invaluable tools for me to get my Gigabyte GA EX-58 UDP with i7 920 ESXI enabled. Utilizing the advice from this post and others all is working great. Some quick notes to help others with the same configuration.

I utilized the same drivers exactly as attached in this post under RTL8111/8168 and P55 integ. SATA Ctrl. (AHCI) - this post.

viewtopic.php?f=12&t=1272

Utilizing the bash script located at below URL I created my custom ISO:

viewtopic.php?f=12&t=4

Then after failing to get my network connectivity to work reliably both on the LAN and internet and digging through many posts, I found this.

http://social.technet.microsoft.com/For ... c7f1b46462

http://msdn.microsoft.com/en-us/library/aa938424.aspx

- Ip4IpChecksum

- Ip4TcpChecksum

- Ip4TcpLsoV1
Disabling these in the registry and all is well! Voila!


**** UPDATE 022010 for Windows 2003

Here is the link To Disable Task Offloading in Windows 2003. And yes this works.

http://support.microsoft.com/kb/904946


Last edited by ewohmot on Sat Feb 20, 2010 11:44 am, edited 1 time in total.



Sat Jan 02, 2010 4:41 pm
Profile

Joined: Mon Jan 04, 2010 10:10 pm
Posts: 2
Reply with quote
Post Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4
Hey All,

I just got back from the DC after pulling my hair out getting the Intel DG41RQ Motherbord Onboard Nic to work. I updated the oem.tgz with the first attachment in the original post. That got the network card to work, but however the nic hangs often, and requires a reboot.

So, right now I have a box that is not stable... I will try some of the other oem.tgz files noted in this thread and report back my findings. Maybe I will have better luck after a good-nights rest and a few more braincells.


Mon Jan 04, 2010 10:14 pm
Profile

Joined: Mon Jan 04, 2010 10:10 pm
Posts: 2
Reply with quote
Post Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4
Chilluminati 's ZIP worked!

I am using the DG41RQ Motherboard, with an Adaptec RAID Card. All I had to do was use the module from Chill, update the simple.map and presto. No more hangups!

-Israel


Tue Jan 05, 2010 3:42 pm
Profile

Joined: Tue Jan 12, 2010 8:46 pm
Posts: 2
Reply with quote
Post Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4
First, thanks to everyone in this thread/site. It has been my primary source of information through-out my n00b experience with ESXi.

So far, I have things working pretty well on my GigaByte EP45-UD3P with dual 1000Mb 8111c NICs.

First install with the r8168.o appeared to work and then started suffering the hangup's once I put the network under load.

The r8169.o has been working well and is stable (even burned a DVD yesterday for posterity); however, I happened to look at my switch today and noticed I'd went orange (i.e. 10/100) on the ESXi side(s).

I recall that the r8168 was full 1000MB (but unstable). I can't remember if the r8169.o was ever full 1000MB on my switch.

iperf on a Ubuntu server (NAS box) to/from an Ubuntu VM is showing only ~95MBs (tools installed). So either I did something or it was always 100MB/s.

Could someone else using the r8169 check there end? Anyone have any thoughts?

Thanks!
-BoB


Tue Jan 12, 2010 9:31 pm
Profile

Joined: Tue Jan 12, 2010 8:46 pm
Posts: 2
Reply with quote
Post Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4
I take it all back...dark magic must be at work here.

I left the server running load tests on an ubuntu live CD and rebooted this A.M. to find that I'm back at 932Mb/s.

So both RealTek 8111c nics are now a-OK and appear quite stable.

[ ID] Interval Transfer Bandwidth
[ 3] 0.0-30.0 sec 3.29 GBytes 942 Mbits/sec

Thanks!
-BoB


Thu Jan 14, 2010 7:44 am
Profile

Joined: Tue Mar 09, 2010 10:29 am
Posts: 1
Reply with quote
Post Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4
I have been following the instruction on this thread and was able to install ESXi 4.0 on my HP Slimline with Realtek GBE controller. Everything works fine and I can connect to the host machine until I try to download the vSphere Client from the host machine, then the network connection drops. I have to unplug the ethernet and reconnect it to bring it back on. I can ssh to the host but I think after a few minutes the connection also drops. Can someone help me.

Thanks!


Tue Mar 09, 2010 10:38 am
Profile

Joined: Tue May 04, 2010 9:18 am
Posts: 1
Reply with quote
Post Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4
HI everybody,

I am trying to install ESXi 4.0 on a workstation with Asus P6T SE motherboard. I have problems with the custom configuration of the Realtek 8111C Lan controller.

I have tried the solution posted in this thread, but although ESXi now recognizes my LAN, I still can't complete the installation, which freezes when it gets to the "Downloading tools to manage this host from..." step.

I get this message on the console:

"Elf: 2518: Kernel module r8168 was loaded, but has no signature attached"

Can anybody help?

Thanks a lot!

den3b


Tue May 04, 2010 9:27 am
Profile
Site Admin

Joined: Mon Mar 16, 2009 10:13 pm
Posts: 3880
Reply with quote
Post Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4
So you're trying to download the vSphere client? If so you can get it from here - http://downloads.vmware.com/d/details/e ... piZGUlaA==. you have to sign up for a vSphere eval if you don't have access.

_________________
Dave Mishchenko
VMware vExpert 2009-2013
Image
Now available - VMware ESXi: Planning, Implementation, and Security
Also available - vSphere Quick Start Guide


Tue May 04, 2010 2:57 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 113 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6, 7 ... 12  Next

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.