View unanswered posts | View active topics It is currently Sun Nov 18, 2018 5:13 pm



Reply to topic  [ 113 posts ]  Go to page Previous  1 ... 8, 9, 10, 11, 12
 RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4 
Author Message

Joined: Thu Apr 14, 2011 9:20 am
Posts: 11
Reply with quote
Post Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4
effteedee wrote:
Thanks for the help, I have been attempting to get my RTL8111 dual gbit board working properly in ESXi 4.1 over the last few days using this iso creator: http://www.google.com.au/url?sa=t&source=web&cd=1&ved=0CBcQFjAA&url=http%3A%2F%2Fcode.google.com%2Fp%2Fmkesxiaio%2F&ei=bpojTr_VGePUmAW9zMmZAw&usg=AFQjCNH1824wz4WhEK_vZ1XmEfiKJymJDw

At first I tried: http://www.vm-help.com/forum/viewtopic.php?f=12&t=1272&p=9462#p9462
It seemed great at first, but then I realised that while I could manage the ESXi over the network the guest OS' were getting malformed packet issues

Next I used: [url]http://temp.vm-help.com/forum/viewtopic.php?f=12&p=7412#p7412
[/url]
I had to copy the simple.map from the first driver to this one for the iso creator to work. after booting the ESX it could not tell there was a network cable plugged in but was on the network anyway.
It worked better as in the guest OS' could talk on the network and sync at 1gbit, but it would only transfer files at 10mbit, I disabled jumbo packets and TCP Offloat on the guest OS' but nothing helped.
Finally today I tried using the second network port and all of a sudden I am getting 700mbit transfer speeds.

I just thought I should post my experience incase it helps anyone else.



copy that.
Use the RTL8111_8168-8.018.00_P55_integr_SATA_Ctrl.(AHCI).oem.tgz from viewtopic.php?f=12&t=1272&p=9462#p9462
But didn't work. Was kind of half working, e.g when I open google got: "400 Your client has issued a malformed or illegal request. That’s all we know."
This one viewtopic.php?f=12&p=7412#p7412 oem-r8169-esx4.1.tgz by frutis worked but slow, I changed the network port and now seems to be fast. I report back in case goes slow again.

Board: EVGA X58 SLI Part Number: 132-BL-E758-TR BIOS 83xx


First try Realtek Driver viewtopic.php?f=12&t=1272&p=9462#p9462

Code:
~ # esxcfg-nics -l
Name    PCI           Driver      Link Speed     Duplex MAC Address       MTU    Description
vmnic0  0000:07:00.00 r8168       Up   1000Mbps  Full   00:1f:xxx       1500   Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller
vmnic1  0000:08:00.00 r8168       Down 0Mbps     Half   00:1f:xxx       1500   Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller

~ # ethtool -i vmnic0
driver: r8168
version: 8.018.00
firmware-version:
bus-info: 0000:07:00.0


Second try Realtek Driver furits viewtopic.php?f=12&p=7412#p7412
Code:
~ # esxcfg-nics -l
Name    PCI           Driver      Link Speed     Duplex MAC Address       MTU    Description
vmnic0  0000:07:00.00 r8169       Up   1000Mbps  Full   00:1f:xxx       1500   Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller
vmnic1  0000:08:00.00 r8169       Down 0Mbps     Half   00:1f:xxx       1500   Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller

~ # ethtool -i vmnic0
driver: r8169
version: 2.2LK-NAPI
firmware-version:
bus-info: 0000:07:00.0


Tue May 29, 2012 1:40 pm
Profile

Joined: Tue Sep 13, 2011 12:00 pm
Posts: 30
Reply with quote
Post Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4
Tilo wrote:
effteedee wrote:
Thanks for the help, I have been attempting to get my RTL8111 dual gbit board working properly in ESXi 4.1 over the last few days using this iso creator: http://www.google.com.au/url?sa=t&source=web&cd=1&ved=0CBcQFjAA&url=http%3A%2F%2Fcode.google.com%2Fp%2Fmkesxiaio%2F&ei=bpojTr_VGePUmAW9zMmZAw&usg=AFQjCNH1824wz4WhEK_vZ1XmEfiKJymJDw

At first I tried: http://www.vm-help.com/forum/viewtopic.php?f=12&t=1272&p=9462#p9462
It seemed great at first, but then I realised that while I could manage the ESXi over the network the guest OS' were getting malformed packet issues

Next I used: [url]http://temp.vm-help.com/forum/viewtopic.php?f=12&p=7412#p7412
[/url]
I had to copy the simple.map from the first driver to this one for the iso creator to work. after booting the ESX it could not tell there was a network cable plugged in but was on the network anyway.
It worked better as in the guest OS' could talk on the network and sync at 1gbit, but it would only transfer files at 10mbit, I disabled jumbo packets and TCP Offloat on the guest OS' but nothing helped.
Finally today I tried using the second network port and all of a sudden I am getting 700mbit transfer speeds.

I just thought I should post my experience incase it helps anyone else.



copy that.
Use the RTL8111_8168-8.018.00_P55_integr_SATA_Ctrl.(AHCI).oem.tgz from viewtopic.php?f=12&t=1272&p=9462#p9462
But didn't work. Was kind of half working, e.g when I open google got: "400 Your client has issued a malformed or illegal request. That’s all we know."
This one viewtopic.php?f=12&p=7412#p7412 oem-r8169-esx4.1.tgz by frutis worked but slow, I changed the network port and now seems to be fast. I report back in case goes slow again.

Board: EVGA X58 SLI Part Number: 132-BL-E758-TR BIOS 83xx


First try Realtek Driver viewtopic.php?f=12&t=1272&p=9462#p9462

Code:
~ # esxcfg-nics -l
Name    PCI           Driver      Link Speed     Duplex MAC Address       MTU    Description
vmnic0  0000:07:00.00 r8168       Up   1000Mbps  Full   00:1f:xxx       1500   Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller
vmnic1  0000:08:00.00 r8168       Down 0Mbps     Half   00:1f:xxx       1500   Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller

~ # ethtool -i vmnic0
driver: r8168
version: 8.018.00
firmware-version:
bus-info: 0000:07:00.0


Second try Realtek Driver furits viewtopic.php?f=12&p=7412#p7412
Code:
~ # esxcfg-nics -l
Name    PCI           Driver      Link Speed     Duplex MAC Address       MTU    Description
vmnic0  0000:07:00.00 r8169       Up   1000Mbps  Full   00:1f:xxx       1500   Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller
vmnic1  0000:08:00.00 r8169       Down 0Mbps     Half   00:1f:xxx       1500   Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller

~ # ethtool -i vmnic0
driver: r8169
version: 2.2LK-NAPI
firmware-version:
bus-info: 0000:07:00.0


I had the exact same problems, management console worked fine but Guest OSes were all hitting with malformed packets. My solution (I know this is the ESXi4 section) was ESXi5.0 which had drivers out of the box


Tue May 29, 2012 1:48 pm
Profile

Joined: Tue Jan 15, 2013 11:25 am
Posts: 1
Reply with quote
Post Re: RTL8111/8168 and P55 integr. SATA Ctrl. (AHCI) for ESX 4
This is the only driver that works for me on ESXi 4.1. All the other 8168c/8111c drivers listed here: http://vm-help.com/esx40i/customize_oem_tgz.php lead to instability: (1) I can communicate with vSphere client and access VMs via console, but not over the LAN. Can ping, but all other communication to/from guests is garbled. (2) The management network becomes unstable after about 10 minutes.

Even with this stable driver, I get the following error constantly repeated in 'messages':
Code:
Jan 15 19:37:40 vmkernel: 0:18:50:54.164 cpu1:4125)<3>RTNL: assertion failed at vmkdrivers/src26/drivers/net/r8169/r8169.c (1078)

I also have experienced an issue with the network link status showing down and the connection forced to run at 100 mbit. I could still communicate with all VMs though. The only fix I could come up with was using the install disk to 'repair' the installation and re-add all my vmx files to inventory. Restarts, changing cables, etc. did not restore the connection status or allow for 1000 mbit.

By the way, I'm stuck with ESXi 4.1 because of my Highpoint 2710 SAS controller, which isn't supported under ESXi 5.


Tue Jan 15, 2013 12:34 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 113 posts ]  Go to page Previous  1 ... 8, 9, 10, 11, 12

Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.